Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / classes / python-backports-init.bbclass
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 inherit python-dir
17
18 RDEPENDS_${PN} += "python-backports-init"
19
20 do_install_prepend() {
21     rm -rf $(find . -path "*/backports/__init__.py" -type f)
22 }