Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / classes / extrausers-config.bbclass
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 # This bbclass creates users based on EXTRA_USER_PARAMS through
17 # extrausers bbclass and is intended to take config options for 
18 # configuring users uniq environment.
19
20 inherit extrausers
21
22
23 PACKAGE_INSTALL_append = " ${@['', 'base-passwd shadow'][bool(d.getVar('EXTRA_USERS_PARAMS_CONFIG'))]}"
24
25 ROOTFS_POSTPROCESS_COMMAND_append = " set_user_group_config;"
26
27 set_user_group_config () {
28
29 # FIXME: parse EXTRA_USERS_PARAMS_CONFIG for options
30         
31         EXTRA_USERS_PARAMS=" ${EXTRA_USERS_PARAMS_CONFIG}"
32         set_user_group
33
34         #Extend path variable for sysadmin
35         echo 'PATH=/sbin:/usr/sbin:$PATH' >> ${IMAGE_ROOTFS}/home/sysadmin/.bashrc
36         chown sysadmin:sys_protected ${IMAGE_ROOTFS}/home/sysadmin/.bashrc
37 }