c8ce3b5d19171c0825d859aca9cf5bfc3009c03a
[pti/rtp.git] / meta-starlingx / meta-stx-virt / recipes-containers / docker / docker-ce_git.bbappend
1 SRCREV_FORMAT = "opendev"
2 SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
3 SUBPATH0 = "docker-config"
4 DSTSUFX0 = "stx-configfiles"
5
6 LICENSE_append = "& Apache-2.0"
7 LIC_FILES_CHKSUM += "\
8         file://stx-configfiles-LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
9         "
10
11 SRC_URI += " \
12         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
13         "
14
15 RDEPENDS_${PN}_append = " logrotate"
16
17 do_unpack_append() {
18     bb.build.exec_func('do_copy_config_files', d)
19 }
20
21 do_copy_config_files () {
22     cp -f ${WORKDIR}/${DSTSUFX0}/files/LICENSE ${S}/stx-configfiles-LICENSE
23 }
24
25 do_install_append () {
26     rm -f ${D}${sysconfdir}/docker
27     install -d -m 0755 ${D}${sysconfdir}/docker
28     install -d -m 0755 ${D}/${sysconfdir}/pmon.d 
29     install -d -m 0755 ${D}/${sysconfdir}/systemd/system/docker.service.d 
30     
31     install -D -m 644 ${WORKDIR}/${DSTSUFX0}/files/docker-pmond.conf ${D}/${sysconfdir}/pmon.d/docker.conf
32     
33     install -D -m 644 ${WORKDIR}/${DSTSUFX0}/files/docker-stx-override.conf \
34         ${D}/${sysconfdir}/systemd/system/docker.service.d/docker-stx-override.conf
35     install -D -m 644 ${WORKDIR}/${DSTSUFX0}/files/docker.logrotate ${D}/${sysconfdir}/logrotate.d/docker.logrotate
36 }