294c84d9e858b7be525f196b8d31f4cb1d75050d
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-support / ntp / ntp_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 SRCREV_FORMAT = "opendev"
4 SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
5 SUBPATH0 = "ntp-config"
6 DSTSUFX0 = "stx-configfiles"
7
8 LICENSE_append = "& Apache-2.0"
9 LIC_FILES_CHKSUM += "\
10         file://stx-configfiles-LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
11         "
12
13 SRC_URI += " \
14         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
15         "
16
17
18 do_unpack_append() {
19     bb.build.exec_func('do_copy_config_files', d)
20 }
21
22 do_copy_config_files () {
23     cp -pf ${WORKDIR}/${DSTSUFX0}/files/LICENSE ${S}/stx-configfiles-LICENSE
24 }
25
26 do_install_append () {
27         install -D -m644 ${WORKDIR}/${DSTSUFX0}/files/ntpd.sysconfig ${D}/${sysconfdir}/sysconfig/ntpd
28         install -D -m644 ${WORKDIR}/${DSTSUFX0}/files/ntp.conf ${D}/${sysconfdir}/ntp.conf
29 }
30
31 SYSTEMD_AUTO_ENABLE = "disable"
32 RDEPENDS_${PN}_append = " bash"
33
34 FILES_${PN}_append = " ${sysconfdir}/sysconfig/ntpd"