meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-support / libevent / libevent_2.0.21.bb
1 SUMMARY = "An asynchronous event notification library"
2 HOMEPAGE = "http://libevent.org/"
3 BUGTRACKER = "https://github.com/libevent/libevent/issues"
4 SECTION = "libs"
5
6 LICENSE = "BSD"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=45c5316ff684bcfe2f9f86d8b1279559"
8
9 SRC_URI = " \
10     https://github.com/downloads/libevent/libevent/${BP}-stable.tar.gz \
11     file://libevent-obsolete_automake_macros.patch \
12     file://libevent-disable_tests.patch \
13     file://libevent-ipv6-client-socket.patch \
14 "
15
16 SRC_URI[md5sum] = "b2405cc9ebf264aa47ff615d9de527a2"
17 SRC_URI[sha256sum] = "22a530a8a5ba1cb9c080cba033206b17dacd21437762155c6d30ee6469f574f5"
18
19 S = "${WORKDIR}/${BP}-stable"
20
21 inherit openssl10
22
23 PACKAGECONFIG ??= "openssl"
24 PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl10"
25
26 inherit autotools
27
28 # Needed for Debian packaging
29 LEAD_SONAME = "libevent-2.0.so"
30
31 BBCLASSEXTEND = "native nativesdk"