c887329cf4e68b449b31fb49d5a2f3e5cb17df20
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-extended / shadow / shadow_%.bbappend
1 SRCREV_FORMAT = "opendev"
2 SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
3 SUBPATH0 = "shadow-utils-config"
4 DSTSUFX0 = "stx-configfiles"
5 SUBPATH1 = "util-linux-config"
6 DSTSUFX1 = "stx-util-linux"
7
8 LICENSE_append = "& Apache-2.0"
9 LIC_FILES_CHKSUM += "\
10         file://stx-configfiles-LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
11         file://stx-util-linux-LICENSE;beginline=1;endline=10;md5=5801a9b9ee2a1468c289f27bd8ee8af3 \
12         "
13 SRC_URI += " \
14          git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
15          git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX1};branch="r/stx.3.0";subpath=${SUBPATH1};name=opendev \
16         "
17 do_unpack_append() {
18     bb.build.exec_func('do_copy_config_files', d)
19 }
20
21 do_copy_config_files () {
22     cp -pf ${WORKDIR}/stx-configfiles/files/LICENSE ${S}/stx-configfiles-LICENSE
23     cp -pf ${WORKDIR}/stx-util-linux/centos/util-linux-config.spec ${S}/stx-util-linux-LICENSE
24 }
25
26 do_install_append_class-target () { 
27
28     install -d ${D}/${sysconfdir}/pam.d
29     install -m 644 ${WORKDIR}/stx-util-linux/files/stx.su     ${D}/${sysconfdir}/pam.d/su
30     install -m 644 ${WORKDIR}/stx-util-linux/files/stx.login  ${D}/${sysconfdir}/pam.d/login
31
32     install -D -m644 ${WORKDIR}/${DSTSUFX0}/files/login.defs ${D}/${sysconfdir}/login.defs
33     install -D -m644 ${WORKDIR}/${DSTSUFX0}/files/clear_shadow_locks.service  \
34               ${D}/${systemd_system_unitdir}/clear_shadow_locks.service
35 }
36
37 inherit systemd
38 SYSTEMD_PACKAGES += "shadow"
39 SYSTEMD_SERVICE_${PN} = "clear_shadow_locks.service"
40 SYSTEMD_AUTO_ENABLE_${PN} += "enable"