meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-extended / pam / libpam_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2 SRCREV_FORMAT = "opendev"
3 SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
4 SUBPATH = "pam-config"
5 DSTSUFX0 = "stx-configfiles"
6
7 LICENSE_append = " & Apache-2.0"
8 LIC_FILES_CHKSUM += "\
9         file://stx-configfiles-LICENSE;beginline=1;endline=10;md5=fa5ec877c97a75a09b397bccc95b2b87 \
10         "
11
12 SRC_URI += " \
13         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH};name=opendev \
14         file://util-linux-pam-postlogin.patch \
15         "
16
17 do_unpack_append() {
18     bb.build.exec_func('do_copy_config_files', d)
19 }
20
21 do_copy_config_files () {
22     cp -pf ${WORKDIR}/stx-configfiles/centos/pam-config.spec ${S}/stx-configfiles-LICENSE
23 }
24
25 do_install_append () {
26
27     # From util-linux-config patch
28     install -m 644 ${S}/stx.postlogin ${D}/${sysconfdir}/pam.d/postlogin
29
30     install  -m 644 ${WORKDIR}/stx-configfiles/files/sshd.pam        ${D}/${sysconfdir}/pam.d/sshd.pam
31     install  -m 644 ${WORKDIR}/stx-configfiles/files/common-account  ${D}/${sysconfdir}/pam.d/common-account
32     install  -m 644 ${WORKDIR}/stx-configfiles/files/common-auth     ${D}/${sysconfdir}/pam.d/common-auth
33     install  -m 644 ${WORKDIR}/stx-configfiles/files/common-password ${D}/${sysconfdir}/pam.d/common-password
34     install  -m 644 ${WORKDIR}/stx-configfiles/files/common-session  ${D}/${sysconfdir}/pam.d/common-session
35
36     install  -m 644 ${WORKDIR}/stx-configfiles/files/common-session-noninteractive  \
37                 ${D}/${sysconfdir}/pam.d/common-session-noninteractive
38
39     install  -m 644 ${WORKDIR}/stx-configfiles/files/system-auth.pamd ${D}/${sysconfdir}/pam.d/system-auth
40         # A better place is the autoconfig from kickstarter
41         sed -i -e '/password .*pam_ldap.so/,/session .*revoke/ s/^$/password required pam_deny.so\n/g' \
42                 ${D}/${sysconfdir}/pam.d/system-auth
43 }
44
45 RRECOMMENDS_${PN}_append = " \
46     nss-pam-ldapd \
47     libpwquality \
48     pam-plugin-access \
49     pam-plugin-cracklib \
50     pam-plugin-debug \
51     pam-plugin-deny \
52     pam-plugin-echo \
53     pam-plugin-env \
54     pam-plugin-exec \
55     pam-plugin-faildelay \
56     pam-plugin-filter \
57     pam-plugin-ftp \
58     pam-plugin-group \
59     pam-plugin-issue \
60     pam-plugin-keyinit \
61     pam-plugin-lastlog \
62     pam-plugin-limits \
63     pam-plugin-listfile \
64     pam-plugin-localuser \
65     pam-plugin-loginuid \
66     pam-plugin-mail \
67     pam-plugin-mkhomedir \
68     pam-plugin-motd \
69     pam-plugin-namespace \
70     pam-plugin-nologin \
71     pam-plugin-permit \
72     pam-plugin-pwhistory \
73     pam-plugin-rhosts \
74     pam-plugin-rootok \
75     pam-plugin-securetty \
76     pam-plugin-shells \
77     pam-plugin-stress \
78     pam-plugin-succeed-if \
79     pam-plugin-tally \
80     pam-plugin-stress \
81     pam-plugin-succeed-if \
82     pam-plugin-tally \
83     pam-plugin-tally2 \
84     pam-plugin-time \
85     pam-plugin-timestamp \
86     pam-plugin-umask \
87     pam-plugin-unix \
88     pam-plugin-warn \
89     pam-plugin-wheel \
90     pam-plugin-xauth \
91     "