meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / rsync / rsync_%.bbappend
1 SRCREV_FORMAT = "opendev"
2 SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
3 SUBPATH0 = "rsync-config"
4 DSTSUFX0 = "stx-configfiles"
5
6 LICENSE_append = " & Apache-2.0"
7 LIC_FILES_CHKSUM += "\
8         file://stx-configfiles-LICENSE;beginline=1;endline=10;md5=0b819b48e21c87ba7f5d0502e304af61 \
9         "
10 SRC_URI += " \
11         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
12         "
13
14 inherit systemd
15 SYSTEMD_PACKAGES = "${PN}"
16 SYSTEMD_SERVICE_${PN} = "rsync.service"
17 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
18
19 do_unpack_append() {
20     bb.build.exec_func('do_copy_config_files', d)
21 }
22
23 do_copy_config_files () {
24     cp -pf ${WORKDIR}/${DSTSUFX0}/centos/rsync-config.spec ${S}/stx-configfiles-LICENSE
25 }
26
27
28 do_install_append_class-target() {
29     install -p -D -m 644 ${S}/packaging/systemd/rsync.service ${D}/${systemd_system_unitdir}/rsync.service
30     install -m 644 ${WORKDIR}/${DSTSUFX0}/files/rsyncd.conf  ${D}/${sysconfdir}/rsyncd.conf
31 }
32
33 FILES_${PN}_append = " ${systemd_system_unitdir}"
34
35