d5f3a4c68534d90cb5d5489eea153a769917cdb3
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-neutronclient_git.bb
1
2 DESCRIPTION = "CLI and python client library for OpenStack Neutron"
3 HOMEPAGE = "https://launchpad.net/neutron"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 SRCREV = "680b417111dbbda9e318700286c4efd9055f1af3"
9 SRCNAME = "python-neutronclient"
10 BRANCH = "stable/train"
11 PROTOCOL = "https"
12 PV = "6.12.0+git${SRCPV}"
13 S = "${WORKDIR}/git"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16         
17 inherit setuptools monitor rmargparse
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native\
22         "
23
24 # Satisfy setup.py 'setup_requires'
25 DEPENDS += " \
26         python-pbr-native \
27         "
28
29 RDEPENDS_${PN} += " \
30         python-pbr \
31         python-cliff \
32         python-debtcollector \
33         python-iso8601 \
34         python-netaddr \
35         python-osc-lib \
36         python-oslo.i18n \
37         python-oslo.serialization \
38         python-oslo.utils \
39         python-os-client-config \
40         python-keystoneauth1 \
41         python-keystoneclient \
42         python-requests \
43         python-simplejson \
44         python-six \
45         python-babel \
46         "
47
48
49 PACKAGECONFIG ?= "bash-completion"
50 PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
51
52 do_install_append() {
53         install -d ${D}/${sysconfdir}/bash_completion.d
54         install -m 664 ${S}/tools/neutron.bash_completion ${D}/${sysconfdir}/bash_completion.d
55 }
56
57 PACKAGES =+ "${BPN}-bash-completion"
58 FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
59
60 MONITOR_CHECKS_${PN} += "\
61         neutron-api-check.sh \
62 "