a047b419ac38fd4b785b9b52f78acc8133834b9b
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-muranoclient_git.bb
1
2 DESCRIPTION = "python-muranoclient"
3 STABLE = "master"
4 PROTOCOL = "https"
5 BRANCH = "master"
6 SRCREV = "70b4392c7f8524ac25dbf3ab0feb3ac4127c1ecf"
7 S = "${WORKDIR}/git"
8 PV = "1.1.1"
9
10 LICENSE = "Apache-2.0"
11
12 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
13
14 SRC_URI = "git://github.com/openstack/python-muranoclient.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
15
16 DEPENDS += " \
17         python \
18         python-pbr-native \
19         "
20
21 inherit setuptools
22
23 RDEPENDS_${PN}_append = " \
24         bash    \
25         python-pbr \
26         python-prettytable \
27         python-glanceclient \
28         python-keystoneclient \
29         python-iso8601 \
30         python-six \
31         python-babel \
32         python-pyopenssl \
33         python-requests \
34         python-pyyaml \
35         python-yaql \
36         python-osc-lib \
37         python-murano-pkg-check \
38         python-oslo.serialization \
39         python-oslo.utils \
40         python-oslo.log \
41         python-oslo.i18n \
42         "