e4f82a16b5e74e8d09dc921afcd9104a0c8a072d
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-magnumclient_git.bb
1
2 DESCRIPTION = "Python client for containers service"
3 HOMEPAGE = "https://github.com/openstack/python-magnumclient"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
7
8 SRCREV = "37e602d160632a386c2960ec8777bfc65642a9a9"
9 SRCNAME = "python-magnumclient"
10 PROTOCOL = "https"
11 BRANCH = "master"
12 S = "${WORKDIR}/git"
13 PV = "2.12.0+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 DEPENDS += " \
18         python-pip \
19         python-pbr-native \
20         "
21
22 RDEPENDS_${PN} +=" \
23         python-pbr \
24         python-babel \
25         python-stevedore \
26         python-requests \
27         python-oslo.i18n \
28         python-oslo.serialization \
29         python-oslo.utils \
30         python-os-client-config \
31         python-osc-lib \
32         python-prettytable \
33         python-cryptography \
34         python-decorator \
35         "
36
37 inherit setuptools