meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-core / systemd / systemd_241.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 SRCREV_FORMAT = "opendev"
4 SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
5 SUBPATH0 = "systemd-config"
6 DSTSUFX0 = "stx-configfiles"
7 SUBPATH1 = "io-scheduler"
8 DSTSUFX1 = "stx-io-scheduler"
9
10
11 LICENSE_append = "& Apache-2.0"
12 LIC_FILES_CHKSUM += "\
13         file://stx-configfiles-LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
14         file://stx-ioscheduler-LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
15         "
16 SRC_URI += " \
17         file://0900-inject-milisec-in-syslog-date.patch \
18         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
19         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX1};branch="r/stx.3.0";subpath=${SUBPATH1};name=opendev \
20         "
21
22 STX_DEFAULT_LOCALE ?= "en_US.UTF-8"
23
24 do_unpack_append() {
25     bb.build.exec_func('do_copy_config_files', d)
26 }
27
28 do_copy_config_files () {
29     cp -f ${WORKDIR}/${DSTSUFX0}/files/LICENSE ${S}/stx-configfiles-LICENSE
30     cp -f ${WORKDIR}/${DSTSUFX1}/centos/files/LICENSE ${S}/stx-ioscheduler-LICENSE
31 }
32
33 do_install_append () {
34         install -d ${D}${sysconfdir}
35         echo LANG=${STX_DEFAULT_LOCALE} >> ${D}${sysconfdir}/locale.conf
36         
37         install -d -m 0755 ${D}/${sysconfdir}/udev/rules.d
38         install -d -m 0755 ${D}/${sysconfdir}/tmpfiles.d
39         install -d -m 0755 ${D}/${sysconfdir}/systemd
40         
41         install -m644 ${WORKDIR}/${DSTSUFX0}/files/60-persistent-storage.rules \
42                 ${D}/${sysconfdir}/udev/rules.d/60-persistent-storage.rules
43
44         install -m644 ${WORKDIR}/${DSTSUFX0}/files/systemd.conf.tmpfiles.d ${D}/${sysconfdir}/tmpfiles.d/systemd.conf
45         install -m644 ${WORKDIR}/${DSTSUFX0}/files/tmp.conf.tmpfiles.d ${D}/${sysconfdir}/tmpfiles.d/tmp.conf
46         install -m644 ${WORKDIR}/${DSTSUFX0}/files/tmp.mount ${D}/${sysconfdir}/systemd/system/tmp.mount
47         install -m644 ${WORKDIR}/${DSTSUFX1}/centos/files/60-io-scheduler.rules \
48                 ${D}/${sysconfdir}/udev/rules.d/60-io-scheduler.rules
49
50 }
51
52
53 FILES_${PN} += "${sysconfdir}/locale.conf"
54
55 PACKAGECONFIG_append = " \
56     coredump \
57 "