1840341b6ad502546f683807c84f27bb825926ec
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-core / systemd / systemd-conf_241.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 SRCREV_FORMAT = "opendev"
4 SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
5 SUBPATH0 = "systemd-config"
6 DSTSUFX0 = "stx-configfiles"
7
8 LICENSE_append = "& Apache-2.0"
9 LIC_FILES_CHKSUM += "\
10         file://stx-configfiles-LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
11         "
12
13 SRC_URI += " \
14         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
15         "
16
17 do_unpack_append() {
18     bb.build.exec_func('do_copy_config_files', d)
19 }
20
21 do_copy_config_files () {
22     cp -f ${WORKDIR}/${DSTSUFX0}/files/LICENSE ${S}/stx-configfiles-LICENSE
23 }
24
25
26 do_install_append () {
27         install -d -m 0755 ${D}/${sysconfdir}/systemd
28         install -m644 ${WORKDIR}/${DSTSUFX0}/files/journald.conf ${D}/${sysconfdir}/systemd/journald.conf
29         chmod 644 ${D}/${sysconfdir}/systemd/journald.conf
30 }