adb5aecb4756c447cbebdf91628cee79cd29008f
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-core / initscripts / initscripts_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 SRCREV_FORMAT = "opendev"
4 SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
5 SUBPATH0 = "initscripts-config"
6 DSTSUFX0 = "stx-configfiles"
7
8 LICENSE_append = "& Apache-2.0"
9 LIC_FILES_CHKSUM += " \
10         file://stx-configfiles/centos/initscripts-config.spec;beginline=1;endline=10;md5=5c43895c2c3756125227c74209b8b791 \
11         "
12
13 SRC_URI += " \
14         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
15         "
16
17 inherit systemd
18 SYSTEMD_PACKAGES += "${PN}"
19 SYSTEMD_SERVICE_${PN}_append = "mountnfs.service"
20 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
21 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
22
23 do_install_append () {
24     install -d  -m 755 ${D}/${sysconfdir}/sysconfig
25     install -d  -m 755 ${D}/${sysconfdir}/init.d
26     install -d  -m 755 ${D}/${systemd_system_unitdir}
27
28     install -m  644 ${WORKDIR}/${DSTSUFX0}/files/sysconfig-network.conf ${D}/${sysconfdir}/sysconfig/network
29     install -m  755 ${WORKDIR}/${DSTSUFX0}/files/mountnfs.sh ${D}/${sysconfdir}/init.d/mountnfs
30     install -m  644 ${WORKDIR}/${DSTSUFX0}/files/mountnfs.service ${D}/${systemd_system_unitdir}/mountnfs.service
31 }