a0281d45e9967c5f2b2eb832bfd163f84d7f6bf7
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-core / base-files / base-files_%.bbappend
1 SRCREV_FORMAT = "opendev"
2 SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
3 SUBPATH0 = "setup-config"
4 DSTSUFX0 = "stx-configfiles"
5
6 LICENSE_append = "& Apache-2.0"
7 LIC_FILES_CHKSUM += "\
8         file://stx-configfiles-LICENSE;beginline=1;endline=10;md5=0ba4936433e3eb7acdd7d236af0d2496 \
9         "
10
11 SRC_URI += " \
12         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
13         "
14
15 do_unpack_append() {
16     bb.build.exec_func('do_copy_config_files', d)
17 }
18
19 do_copy_config_files () {
20     cp -pf ${WORKDIR}/stx-configfiles/centos/setup-config.spec ${S}/stx-configfiles-LICENSE
21 }
22
23 do_install_append() {
24
25     install -d ${D}/${sysconfdir}/profile.d
26     install -m 644 ${WORKDIR}/${DSTSUFX0}/files/motd ${D}/${sysconfdir}/motd
27     install -m 644 ${WORKDIR}/${DSTSUFX0}/files/prompt.sh ${D}/${sysconfdir}/profile.d/prompt.sh
28     install -m 644 ${WORKDIR}/${DSTSUFX0}/files/custom.sh ${D}/${sysconfdir}/profile.d/custom.sh
29    # chmod 600 ${D}/{sysconfdir}/exports
30    # chmod 600 ${D}/{sysconfdir}/fstab
31 }