kvm-timer-advance-setup: update for stx 5.0
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-metal / python-inventoryclient.bb
1 require metal-common.inc
2
3 SUBPATH0 = "python-inventoryclient/inventoryclient"
4
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
8
9 RDEPENDS_${PN}_append = " \
10         python \
11         python-pbr \
12         python-six \
13         python-oslo.i18n \
14         python-oslo.utils \
15         python-requests \
16         bash \
17         bash-completion \
18         "
19
20
21 do_install_append () {
22         
23         install -d -m 755 ${D}/${sysconfdir}/bash_completion.d
24         install -p -D -m 664 tools/inventory.bash_completion ${D}/${sysconfdir}/bash_completion.d
25
26 }
27
28 _FILES_${PN}_append = " \
29         ${bindir}/inventory \
30         ${sysconfdir}/bash_completion.d/inventory.bash_completion \
31         ${libdir}/python2.7/site-packages/inventoryclient-*.egg-info/ \
32         ${libdir}/python2.7/site-packages/inventoryclient/ \
33         "