meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-integ / kvm-timer-advance-setup.bb
1 DESCRIPTION = "StarlingX KVM Timer Advance Package"
2
3 STABLE = "starlingx/master"
4 PROTOCOL = "https"
5 BRANCH = "r/stx.3.0"
6 SRCNAME = "integ"
7 SRCREV = "0bf4b546df8c7fdec8cfc6cb6f71b9609ee54306"
8 S = "${WORKDIR}/git"
9 PV = "1.0.0"
10
11 LICENSE = "Apache-2.0 & GPL-2.0"
12 LIC_FILES_CHKSUM = "file://virt/kvm-timer-advance/files/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
13
14 RDEPENDS_${PN}_append = " \
15         systemd \
16         bash \
17         "
18
19
20 SRC_URI = "git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
21         "
22 inherit setuptools systemd
23 SYSTEMD_PACKAGES += " ${PN}"
24 SYSTEMD_SERVICE_${PN} = "kvm_timer_advance_setup.service"
25
26 do_configure[noexec] = "1"
27 do_compile[noexec] = "1"
28
29 do_install () {
30         
31 # kvm-timer-advance
32
33         install -p -D -m 0755 ${S}/virt/kvm-timer-advance/files/setup_kvm_timer_advance.sh \
34                         ${D}/${bindir}/setup_kvm_timer_advance.sh
35         install -p -D -m 444 ${S}/virt/kvm-timer-advance/files/kvm_timer_advance_setup.service \
36                         ${D}/${systemd_system_unitdir}/kvm_timer_advance_setup.service
37
38 }