c65203d95bab818ae574c0fb4b535251ec73b838
[pti/rtp.git] / meta-starlingx / meta-stx-distro / recipes-core / packagegroups / packagegroup-stx.bb
1
2 SUMMARY = "StarlingX stx packages"
3
4 PR = "r0"
5
6 #
7 # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
8 #
9
10 PACKAGE_ARCH = "${MACHINE_ARCH}"
11 inherit packagegroup
12
13 PROVIDES = "${PACKAGES}"
14 PACKAGES = " \
15         packagegroup-stx-upstream \
16         packagegroup-stx-puppet \
17         packagegroup-stx-fault \
18         packagegroup-stx-metal \
19         packagegroup-stx-nfv \
20         packagegroup-stx-monitoring \
21         packagegroup-stx-ha \
22         packagegroup-stx-config \
23         packagegroup-stx-config-files \
24         packagegroup-stx-distributedcloud \
25         packagegroup-stx-update \
26         packagegroup-stx-integ \
27         packagegroup-stx-utilities \
28         packagegroup-stx-armada-app \
29         "
30
31 RDEPENDS_packagegroup-stx-puppet = "\
32         stx-puppet \
33         puppet-dcdbsync \
34         puppet-dcmanager \
35         puppet-dcorch \
36         puppet-fm \
37         puppet-mtce \
38         puppet-nfv \
39         puppet-patching \
40         puppet-smapi \
41         puppet-sshd \
42         puppet-sysinv \
43         puppet-manifests \
44         "
45
46 RDEPENDS_packagegroup-stx-config = " \
47         config-gate-worker \
48         config-gate \
49         controllerconfig \
50         cgts-client \
51         sysinv-agent \
52         sysinv \
53         workerconfig-subfunction \
54         tsconfig \
55         "
56
57 RDEPENDS_packagegroup-stx-config-files  = " \
58         lighttpd \
59         lighttpd-module-proxy \
60         lighttpd-module-setenv \
61         dnsmasq \
62         shadow \
63         openldap \
64         ntp \
65         haproxy \
66         syslog-ng \ 
67         sudo \
68         docker-ce \
69         openvswitch \
70         systemd \
71         nfs-utils \
72         nfs-utils-config \
73         iptables \
74         logrotate \
75         mlx4-init \
76         initscripts \
77         procps \
78         iscsi-initiator-utils \
79         memcached \
80         net-snmp \
81         net-snmp-server-snmpd \
82         net-snmp-server-snmptrapd \
83         libpam-runtime \
84         rabbitmq-server \
85         rsync \
86         base-files \
87         audit \
88         auditd \
89         audit-python \
90         "
91
92 RDEPENDS_packagegroup-stx-fault = " \
93         fm-api \
94         fm-common \
95         fm-doc \
96         fm-mgr \
97         fm-rest-api \
98         python-fmclient \
99         snmp-audittrail \
100         snmp-ext \
101         "
102
103 RDEPENDS_packagegroup-stx-ha = " \
104         sm-common-libs \
105         libsm-common \
106         sm \
107         sm-db \
108         sm-api \
109         sm-client \
110         sm-tools \
111         sm-eru \
112         stx-ocf-scripts \
113         "
114
115 RDEPENDS_packagegroup-stx-metal = " \
116         inventory \
117         mtce \
118         mtce-pmon \
119         mtce-hwmon \
120         mtce-hostw \
121         mtce-lmon \
122         mtce-compute \
123         mtce-control \
124         mtce-storage \
125         python-inventoryclient \
126         pxe-network-installer \
127         platform-kickstarts \
128         "
129
130 RDEPENDS_packagegroup-stx-monitoring = " \
131         collectd-extensions \
132         influxdb-extensions \
133         monitor-tools \
134         vm-topology \
135         "
136
137 RDEPENDS_packagegroup-stx-distributedcloud = " \
138         distributedcloud-dcmanager \
139         distributedcloud-dcorch \
140         distributedcloud-dcdbsync \
141         distributedcloud-ocf \
142         "
143
144 RDEPENDS_packagegroup-stx-nfv = " \
145         nfv-common \
146         nfv-plugins \
147         nfv-tools \
148         nfv-vim \
149         nfv-client \
150         mtce-guest\
151         "
152
153 RDEPENDS_packagegroup-stx-upstream = " \
154         barbican \
155         python-neutronclient \
156         python-aodhclient \
157         python-barbican \
158         python-barbicanclient \
159         python-cinderclient \
160         python-glanceclient \
161         python-gnocchiclient \
162         python-django-horizon \
163         python-heatclient \
164         python-ironicclient \
165         python-keystoneauth1 \
166         python-keystoneclient \
167         python-magnumclient \
168         python-muranoclient \
169         python-novaclient \
170         python-openstackclient \
171         python-openstacksdk \
172         python-pankoclient \
173         openstack-ras \
174         "
175
176 RDEPENDS_packagegroup-stx-update = " \
177         cgcs-patch \
178         cgcs-patch-agent \
179         cgcs-patch-controller \
180         enable-dev-patch \
181         patch-alarm \
182         "
183
184 RDEPENDS_packagegroup-stx-integ = " \
185         dpkg \
186         dtc \
187         ibsh \
188         python-redfishtool \
189         puppet-boolean \
190         puppetlabs-create-resources \
191         puppet-dnsmasq \
192         puppet-drbd \
193         puppet-filemapper \
194         puppet-ldap \
195         puppetlabs-lvm \
196         puppet-network \
197         puppet-nslcd \
198         puppetlabs-postgresql \
199         puppet-puppi \
200         mariadb \
201         drbd-utils \
202         docker-distribution \
203         docker-forward-journald \
204         etcd \
205         kubernetes \
206         ldapscripts \
207         python-3parclient \
208         python-cherrypy \
209         python-lefthandclient \
210         python-setuptools \
211         python-ryu \
212         spectre-meltdown-checker \
213         kvm-timer-advance-setup \
214         ceph \
215         lldpd \
216         lvm2 \
217         tzdata \
218         "
219
220 RDEPENDS_packagegroup-stx-utilities = " \
221         build-info \
222         python-cephclient \
223         ceph-manager \
224         stx-ssl \
225         collector \
226         collect-engtools \
227         logmgmt \
228         namespace-utils \
229         nfscheck \
230         stx-extensions \
231         worker-utils \
232         update-motd \
233         platform-util \
234         pci-irq-affinity \
235         "
236
237 RDEPENDS_packagegroup-stx-armada-app = "\
238         monitor-helm \
239         monitor-helm-elastic \
240         openstack-helm \
241         openstack-helm-infra \
242         stx-monitor-helm \
243         stx-openstack-helm \
244         stx-platform-helm \
245         "