6b910cc21303d24a4542482564eeda446aeb31fa
[pti/rtp.git] / meta-starlingx / meta-stx-distro / recipes-core / packagegroups / packagegroup-stx.bb
1
2 SUMMARY = "StarlingX stx packages"
3
4 PR = "r0"
5
6 #
7 # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
8 #
9
10 PACKAGE_ARCH = "${MACHINE_ARCH}"
11 inherit packagegroup
12
13 PROVIDES = "${PACKAGES}"
14 PACKAGES = " \
15         packagegroup-stx-upstream \
16         packagegroup-stx-puppet \
17         packagegroup-stx-fault \
18         packagegroup-stx-metal \
19         packagegroup-stx-nfv \
20         packagegroup-stx-monitoring \
21         packagegroup-stx-ha \
22         packagegroup-stx-config \
23         packagegroup-stx-config-files \
24         packagegroup-stx-distributedcloud \
25         packagegroup-stx-update \
26         packagegroup-stx-integ \
27         packagegroup-stx-utilities \
28         packagegroup-stx-armada-app \
29         "
30
31 RDEPENDS_packagegroup-stx-puppet = "\
32         stx-puppet \
33         puppet-dcdbsync \
34         puppet-dcmanager \
35         puppet-dcorch \
36         puppet-fm \
37         puppet-mtce \
38         puppet-nfv \
39         puppet-patching \
40         puppet-smapi \
41         puppet-sshd \
42         puppet-sysinv \
43         puppet-manifests \
44         "
45
46 RDEPENDS_packagegroup-stx-config = " \
47         config-gate-worker \
48         config-gate \
49         controllerconfig \
50         cgts-client \
51         sysinv-agent \
52         sysinv \
53         workerconfig-subfunction \
54         tsconfig \
55         "
56
57 RDEPENDS_packagegroup-stx-config-files  = " \
58         lighttpd \
59         lighttpd-module-proxy \
60         lighttpd-module-setenv \
61         dnsmasq \
62         shadow \
63         openldap \
64         ntp \
65         haproxy \
66         syslog-ng \ 
67         sudo \
68         docker-ce \
69         openvswitch \
70         systemd \
71         nfs-utils \
72         nfs-utils-config \
73         iptables \
74         logrotate \
75         mlx4-init \
76         initscripts \
77         procps \
78         iscsi-initiator-utils \
79         memcached \
80         net-snmp \
81         net-snmp-server-snmpd \
82         net-snmp-server-snmptrapd \
83         libpam-runtime \
84         rabbitmq-server \
85         rsync \
86         base-files \
87         audit \
88         auditd \
89         audit-python \
90         "
91
92 RDEPENDS_packagegroup-stx-fault = " \
93         fm-api \
94         fm-common \
95         fm-doc \
96         fm-mgr \
97         fm-rest-api \
98         python-fmclient \
99         snmp-audittrail \
100         snmp-ext \
101         "
102
103 RDEPENDS_packagegroup-stx-ha = " \
104         sm-common-libs \
105         libsm-common \
106         sm \
107         sm-db \
108         sm-api \
109         sm-client \
110         sm-tools \
111         sm-eru \
112         stx-ocf-scripts \
113         "
114
115 RDEPENDS_packagegroup-stx-metal = " \
116         mtce \
117         mtce-pmon \
118         mtce-hwmon \
119         mtce-hostw \
120         mtce-lmon \
121         mtce-compute \
122         mtce-control \
123         mtce-storage \
124         pxe-network-installer \
125         platform-kickstarts \
126         "
127
128 RDEPENDS_packagegroup-stx-monitoring = " \
129         collectd-extensions \
130         influxdb-extensions \
131         monitor-tools \
132         vm-topology \
133         "
134
135 RDEPENDS_packagegroup-stx-distributedcloud = " \
136         distributedcloud-dcmanager \
137         distributedcloud-dcorch \
138         distributedcloud-dcdbsync \
139         distributedcloud-ocf \
140         "
141
142 RDEPENDS_packagegroup-stx-nfv = " \
143         nfv-common \
144         nfv-plugins \
145         nfv-tools \
146         nfv-vim \
147         nfv-client \
148         mtce-guest\
149         "
150
151 RDEPENDS_packagegroup-stx-upstream = " \
152         barbican \
153         python-neutronclient \
154         python-aodhclient \
155         python-barbican \
156         python-barbicanclient \
157         python-cinderclient \
158         python-glanceclient \
159         python-gnocchiclient \
160         python-django-horizon \
161         python-heatclient \
162         python-ironicclient \
163         python-keystoneauth1 \
164         python-keystoneclient \
165         python-magnumclient \
166         python-muranoclient \
167         python-novaclient \
168         python-openstackclient \
169         python-openstacksdk \
170         python-pankoclient \
171         openstack-ras \
172         "
173
174 RDEPENDS_packagegroup-stx-update = " \
175         cgcs-patch \
176         cgcs-patch-agent \
177         cgcs-patch-controller \
178         enable-dev-patch \
179         patch-alarm \
180         "
181
182 RDEPENDS_packagegroup-stx-integ = " \
183         dpkg \
184         dtc \
185         ibsh \
186         python-redfishtool \
187         puppet-boolean \
188         puppetlabs-create-resources \
189         puppet-dnsmasq \
190         puppet-drbd \
191         puppet-filemapper \
192         puppet-ldap \
193         puppetlabs-lvm \
194         puppet-network \
195         puppet-nslcd \
196         puppetlabs-postgresql \
197         puppet-puppi \
198         mariadb \
199         drbd-utils \
200         docker-distribution \
201         docker-forward-journald \
202         etcd \
203         kubernetes \
204         ldapscripts \
205         python-3parclient \
206         python-cherrypy \
207         python-lefthandclient \
208         python-setuptools \
209         python-ryu \
210         spectre-meltdown-checker \
211         kvm-timer-advance-setup \
212         ceph \
213         lldpd \
214         lvm2 \
215         tzdata \
216         "
217
218 RDEPENDS_packagegroup-stx-utilities = " \
219         build-info \
220         python-cephclient \
221         ceph-manager \
222         stx-ssl \
223         collector \
224         collect-engtools \
225         logmgmt \
226         namespace-utils \
227         nfscheck \
228         stx-extensions \
229         worker-utils \
230         update-motd \
231         platform-util \
232         pci-irq-affinity \
233         "
234
235 RDEPENDS_packagegroup-stx-armada-app = "\
236         monitor-helm \
237         monitor-helm-elastic \
238         openstack-helm \
239         openstack-helm-infra \
240         stx-monitor-helm \
241         stx-openstack-helm \
242         stx-platform-helm \
243         "