meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppetlabs-postgresql_git.bbappend
1
2 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3 SRC_URI += " \
4         file://${BPN}/0001-Roll-up-TIS-patches.patch \
5         file://${BPN}/0002-remove-puppetlabs-apt-as-a-requirement.patch \
6         file://${BPN}/0003-puppetlabs-postgresql-account-for-naming-diffs.patch \
7         file://${BPN}/0004-poky-postgresql-updates.patch \
8         file://${BPN}/0005-puppetlabs-postgresql-poky.patch \
9         file://${BPN}/0006-adjust_path-remove-refs-to-local-bin.patch \
10         file://${BPN}/postgresql.service \
11         "
12
13 #       file://${PN}/0004-postgresql-service-restart-with-systemctl.patch 
14
15 RDEPENDS_${PN}_append = " \
16         postgresql \
17         postgresql-contrib \
18         postgresql-client \
19         postgresql-timezone \
20         postgresql-plperl \
21         postgresql-plpython \
22         "
23 #postgresql-dev
24 #postgresql-pltcl
25 #postgresql-setup
26
27
28 do_install_append() {
29         install -d -m0755 ${D}/usr/lib/systemd/system
30         install -m0644 ${WORKDIR}/${PN}/postgresql.service ${D}/usr/lib/systemd/system
31 }
32
33 FILES_${PN}_append = " /usr/lib/systemd/system/postgresql.service"
34
35 inherit openssl10