meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-keystone_git.bbappend
1
2 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3 SRC_URI += " \
4         file://${PN}/0001-pike-rebase-squash-titanium-patches.patch \
5         file://${PN}/0002-remove-the-Keystone-admin-app.patch \
6         file://${PN}/0003-remove-eventlet_bindhost-from-Keystoneconf.patch \
7         file://${PN}/0004-escape-special-characters-in-bootstrap.patch \
8         file://${PN}/0005-Add-support-for-fernet-receipts.patch \
9         file://${PN}/0007-puppet-keystone-specify-full-path-to-openrc.patch \
10         file://${PN}/0008-params.pp-fix-the-service-name-of-openstack-keystone.patch \
11         "
12
13 do_install_append () {
14         # fix the name of python-memcached
15         sed -i -e 's/python-memcache\b/python-memcached/' ${D}/${datadir}/puppet/modules/keystone/manifests/params.pp
16 }
17
18 RDEPENDS_${PN} += " \
19         python-memcached \
20         python-ldappool \
21         "
22
23 inherit openssl10