7d9c06105daa3506c7d73967c7edd6592dd98028
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-horizon_git.bb
1
2 SUMMARY = "Intended managing the entirety of horizon."
3 DESCRIPTION = " \
4         The horizon module is a thorough attempt to make Puppet capable of \
5         managing the entirety of horizon. Horizon is a fairly classic django \
6         application, which results in a fairly simply Puppet module.\
7         "
8
9 # HOMEPAGE = "https://github.com/openstack/puppet-horizon"
10 LICENSE = "Apache-2.0"
11 LIC_FILES_CHKSUM = "file://LICENSE;md5=12a15a9ebddda7d856c783f745e5ee47"
12
13 PV = "11.5.0"
14 SRCREV = "d75706e38fdf63f9c3174a526a7d07799390dfeb"
15 PROTOCOL = "https"
16 BRANCH = "stable/pike"
17 S = "${WORKDIR}/git"
18
19 SRC_URI = "git://github.com/openstack/puppet-horizon.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
20         file://${PN}/Add-gemspec.patch \
21         "
22
23 inherit ruby
24
25 DEPENDS += " \
26         ruby \
27         facter \
28         "
29
30 RDEPENDS_${PN} += " \
31         ruby \
32         facter \
33         puppet \
34         perl \
35         "
36
37 RUBY_INSTALL_GEMS = "puppet-horizon-${PV}.gem"
38
39 do_install_append() { 
40         install -d -m 0755 ${D}/${datadir}/puppet/modules/horizon
41         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/horizon
42 }
43
44 FILES_${PN} += " ${datadir}"