a201e0a1911e9a25fa81eb4a73286caea65fa859
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-barbican_git.bb
1
2 SUMMARY = "Puppet module for OpenStack Barbican"
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=fce88ac1cd1315adf28a52502c9f7f6b"
6
7 RDEPENDS_${PN} += " \
8         puppetlabs-inifile \
9         "
10
11 PV = "11.3.0"
12 SRCREV = "8241a1d13be6c3ee6344fa46dcfc045439044e76"
13 PROTOCOL = "https"
14 BRANCH = "stable/pike"
15 S = "${WORKDIR}/git"
16
17 SRC_URI = "git://github.com/openstack/puppet-barbican.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
18         file://puppet-barbican/Add-gemspec.patch \
19         "
20
21 inherit ruby
22
23 DEPENDS += " \
24         ruby \
25         facter \
26         "
27
28 RDEPENDS_${PN} += " \
29         ruby \
30         facter \
31         puppet \
32         perl \
33         "
34
35 RUBY_INSTALL_GEMS = "puppet-barbican-${PV}.gem"
36
37 do_install_append() {
38         install -d -m 0755 ${D}/${datadir}/puppet/modules/barbican
39         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/barbican
40 }
41
42 FILES_${PN} += " ${datadir}"