meta-oran: add missing license header for recipes
[pti/rtp.git] / meta-oran / recipes-networking / cni / cni_git.bbappend
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 inherit go112
17
18 do_compile_append() {
19     # build ipam plugins
20     cd ${S}/src/import/vendor/github.com/containernetworking/plugins/
21     PLUGINS="$(ls -d plugins/ipam/*)"
22     mkdir -p ${WORKDIR}/plugins/bin/
23     for p in $PLUGINS; do
24         plugin="$(basename "$p")"
25         echo "building: $p"
26         go build -o ${WORKDIR}/plugins/bin/$plugin github.com/containernetworking/plugins/$p
27     done
28 }