meta-oran: add missing license header for recipes
[pti/rtp.git] / meta-oran / recipes-devtools / go / go_1.12.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 require go-${PV}.inc
17 require recipes-devtools/go/go-target.inc
18
19 export GOBUILDMODE=""
20
21 # Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
22 # doesn't support -buildmode=pie, so skip the QA checking for mips and its
23 # variants.
24 python() {
25     if 'mips' in d.getVar('TARGET_ARCH'):
26         d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
27     else:
28         d.setVar('GOBUILDMODE', 'pie')
29 }