meta-oran: add missing license header for recipes
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / node-feature-discovery_0.5.0.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Node feature discovery for Kubernetes"
17 DESCRIPTION = "\
18   This software enables node feature discovery for Kubernetes. \
19   It detects hardware features available on each node in a Kubernetes \
20   cluster, and advertises those features using node labels. \
21   \
22   NFD consists of two software components: \
23     - nfd-master is responsible for labeling Kubernetes node objects \
24     - nfd-worker is detects features and communicates them to nfd-master. \
25       One instance of nfd-worker is supposed to be run on each node of the \
26       cluster \
27 "
28 HOMEPAGE = "https://github.com/kubernetes-sigs/node-feature-discovery"
29
30 LICENSE = "Apache-2.0"
31 LIC_FILES_CHKSUM = "file://LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
32
33 SRC_URI = "\
34     https://github.com/kubernetes-sigs/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
35 "
36
37 SRC_URI[md5sum] = "8130b178e2d5f5aadcec95210b2882d5"
38 SRC_URI[sha256sum] = "f351d69e3dbc0e8babe4365e0b5a766cf69e566f89c0191e686f653e17e50b6d"
39
40 S = "${WORKDIR}/${BPN}-${PV}"
41
42 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
43
44 do_configure() {
45     :
46 }
47
48 do_compile() {
49     :
50 }
51
52 do_install() {
53     install -d ${D}${K8S_PLUGINS}
54     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
55     install -m 644 ${S}/nfd-daemonset-combined.yaml.template ${D}${K8S_PLUGINS}
56     install -m 644 ${S}/nfd-worker.conf.example ${D}${K8S_PLUGINS}
57     install -m 644 ${S}/nfd-worker-job.yaml.template ${D}${K8S_PLUGINS}
58     install -m 644 ${S}/nfd-master.yaml.template ${D}${K8S_PLUGINS}/nfd-master.yaml
59     install -m 644 ${S}/nfd-worker-daemonset.yaml.template ${D}${K8S_PLUGINS}/nfd-worker-daemonset.yaml
60 }