kubernetes-plugins: remove img packages
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / node-feature-discovery_0.4.0.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4
5 SUMMARY = "Node feature discovery for Kubernetes"
6 DESCRIPTION = "\
7   This software enables node feature discovery for Kubernetes. \
8   It detects hardware features available on each node in a Kubernetes \
9   cluster, and advertises those features using node labels. \
10   \
11   NFD consists of two software components: \
12     - nfd-master is responsible for labeling Kubernetes node objects \
13     - nfd-worker is detects features and communicates them to nfd-master. \
14       One instance of nfd-worker is supposed to be run on each node of the \
15       cluster \
16 "
17 HOMEPAGE = "https://github.com/kubernetes-sigs/node-feature-discovery"
18
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
21
22 SRC_URI = "\
23     https://github.com/kubernetes-sigs/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
24 "
25
26 SRC_URI[md5sum] = "16bcac1d904351a88faa5c6752420ce5"
27 SRC_URI[sha256sum] = "c9f826e6c7a42161befc155ca0f465ac5667903e74c857e978a99c74574f635e"
28
29 S = "${WORKDIR}/${BPN}-${PV}"
30
31 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
32
33 do_configure() {
34     :
35 }
36
37 do_compile() {
38     :
39 }
40
41 do_install() {
42     install -d ${D}${K8S_PLUGINS}
43     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
44     install -m 644 ${S}/nfd-daemonset-combined.yaml.template ${D}${K8S_PLUGINS}
45     install -m 644 ${S}/nfd-worker.conf.example ${D}${K8S_PLUGINS}
46     install -m 644 ${S}/nfd-worker-job.yaml.template ${D}${K8S_PLUGINS}
47     install -m 644 ${S}/nfd-master.yaml.template ${D}${K8S_PLUGINS}/nfd-master.yaml
48     install -m 644 ${S}/nfd-worker-daemonset.yaml.template ${D}${K8S_PLUGINS}/nfd-worker-daemonset.yaml
49 }