node-feature-discovery: add new recipe
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / node-feature-discovery_0.4.0.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4
5 SUMMARY = "Node feature discovery for Kubernetes"
6 DESCRIPTION = "\
7   This software enables node feature discovery for Kubernetes. \
8   It detects hardware features available on each node in a Kubernetes \
9   cluster, and advertises those features using node labels. \
10   \
11   NFD consists of two software components: \
12     - nfd-master is responsible for labeling Kubernetes node objects \
13     - nfd-worker is detects features and communicates them to nfd-master. \
14       One instance of nfd-worker is supposed to be run on each node of the \
15       cluster \
16 "
17 HOMEPAGE = "https://github.com/kubernetes-sigs/node-feature-discovery"
18
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
21
22 SRC_URI = "\
23     https://github.com/kubernetes-sigs/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
24     file://docker-img-nfd-v0.4.0.tar.bz2;unpack=0 \
25 "
26
27 SRC_URI[md5sum] = "16bcac1d904351a88faa5c6752420ce5"
28 SRC_URI[sha256sum] = "c9f826e6c7a42161befc155ca0f465ac5667903e74c857e978a99c74574f635e"
29
30 S = "${WORKDIR}/${BPN}-${PV}"
31
32 PACKAGES =+ "${PN}-img"
33
34 DOCKER_IMG = "/opt/docker_images/${BPN}"
35 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
36
37 do_install() {
38     install -d ${D}${K8S_PLUGINS}
39     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
40     install -m 644 ${S}/nfd-daemonset-combined.yaml.template ${D}${K8S_PLUGINS}
41     install -m 644 ${S}/nfd-worker.conf.example ${D}${K8S_PLUGINS}
42     install -m 644 ${S}/nfd-worker-job.yaml.template ${D}${K8S_PLUGINS}
43     install -m 644 ${S}/nfd-master.yaml.template ${D}${K8S_PLUGINS}/nfd-master.yaml
44     install -m 644 ${S}/nfd-worker-daemonset.yaml.template ${D}${K8S_PLUGINS}/nfd-worker-daemonset.yaml
45
46     # Install the saved docker image
47     install -d ${D}${DOCKER_IMG}
48     install -m 644 ${WORKDIR}/docker-img-*.tar.bz2 ${D}${DOCKER_IMG}
49 }
50
51 FILES_${PN}-img = "${DOCKER_IMG}"