d4b023bd8f16ef48f43a7eebd745059f38f69d92
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / multus-cni_3.3.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Multus CNI enables attaching multiple network interfaces to pods in Kubernetes."
17 DESCRIPTION = "\
18   Multus CNI is a container network interface (CNI) plugin for Kubernetes \
19   that enables attaching multiple network interfaces to pods. Typically, \
20   in Kubernetes each pod only has one network interface (apart from a loopback) \
21   -- with Multus you can create a multi-homed pod that has multiple interfaces. \
22   This is accomplished by Multus acting as a "meta-plugin", a CNI plugin that \
23   can call multiple other CNI plugins \
24 "
25 HOMEPAGE = "https://github.com/intel/multus-cni"
26
27 LICENSE = "Apache-2.0"
28 LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
29
30 SRC_URI = "\
31     https://github.com/intel/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
32 "
33
34 SRC_URI[md5sum] = "fa75272319b19a6192f9d607b79829ea"
35 SRC_URI[sha256sum] = "9544fca58e6d1f3943159086651ceb228242b5fd85688bd424d7504c197ec49a"
36
37 S = "${WORKDIR}/${BPN}-${PV}"
38
39 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
40
41 do_install() {
42     install -d ${D}${K8S_PLUGINS}
43     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
44     install -m 644 ${S}/images/entrypoint.sh ${D}${K8S_PLUGINS}
45     install -m 644 ${S}/images/README.md ${D}${K8S_PLUGINS}/README-deployment.md
46     install -m 644 ${S}/images/multus-daemonset-pre-1.16.yml ${D}${K8S_PLUGINS}/multus-daemonset-pre-1.16.yml
47     install -m 644 ${S}/images/multus-daemonset.yml ${D}${K8S_PLUGINS}/multus-daemonset.yml
48 }