0ec9d6ad9fe14a6638b3749c638e94d689952985
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / multus-cni_3.3.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4
5 SUMMARY = "Multus CNI enables attaching multiple network interfaces to pods in Kubernetes."
6 DESCRIPTION = "\
7   Multus CNI is a container network interface (CNI) plugin for Kubernetes \
8   that enables attaching multiple network interfaces to pods. Typically, \
9   in Kubernetes each pod only has one network interface (apart from a loopback) \
10   -- with Multus you can create a multi-homed pod that has multiple interfaces. \
11   This is accomplished by Multus acting as a "meta-plugin", a CNI plugin that \
12   can call multiple other CNI plugins \
13 "
14 HOMEPAGE = "https://github.com/intel/multus-cni"
15
16 LICENSE = "Apache-2.0"
17 LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
18
19 SRC_URI = "\
20     https://github.com/intel/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
21     file://docker-img-multus-v3.2.tar.bz2;unpack=0 \
22 "
23
24 SRC_URI[md5sum] = "fa75272319b19a6192f9d607b79829ea"
25 SRC_URI[sha256sum] = "9544fca58e6d1f3943159086651ceb228242b5fd85688bd424d7504c197ec49a"
26
27 S = "${WORKDIR}/${BPN}-${PV}"
28
29 PACKAGES =+ "${PN}-img"
30
31 DOCKER_IMG = "/opt/docker_images/${BPN}"
32 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
33
34 do_install() {
35     install -d ${D}${K8S_PLUGINS}
36     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
37     install -m 644 ${S}/images/entrypoint.sh ${D}${K8S_PLUGINS}
38     install -m 644 ${S}/images/README.md ${D}${K8S_PLUGINS}/README-deployment.md
39     install -m 644 ${S}/images/multus-daemonset-pre-1.16.yml ${D}${K8S_PLUGINS}/multus-daemonset.yml
40
41     # Install the saved docker image
42     install -d ${D}${DOCKER_IMG}
43     install -m 644 ${WORKDIR}/docker-img-*.tar.bz2 ${D}${DOCKER_IMG}
44 }
45
46 FILES_${PN}-img = "${DOCKER_IMG}"