2ac4843fa61441960b4a7575e21d762c0a865ef9
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / kubernetes-dashboard_1.10.1.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4
5 SUMMARY = "General-purpose web UI for Kubernetes clusters"
6 DESCRIPTION = "\
7   Kubernetes Dashboard is a general purpose, web-based UI \
8   for Kubernetes clusters. It allows users to manage applications \
9   running in the cluster and troubleshoot them, as well as manage \
10   the cluster itself. \
11 "
12 HOMEPAGE = "https://github.com/kubernetes/dashboard"
13
14 LICENSE = "Apache-2.0"
15 LIC_FILES_CHKSUM = "file://LICENSE;md5=b1e01b26bacfc2232046c90a330332b3"
16
17 SRC_URI = "\
18     https://github.com/kubernetes/dashboard/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
19     file://kubernetes-dashboard-admin.rbac.yaml \
20     file://kubernetes-dashboard.yaml-set-the-NodePort-type.patch \
21 "
22
23 SRC_URI[md5sum] = "52c30b2c4e9cfc31a1ea67144e81513f"
24 SRC_URI[sha256sum] = "088ba30335e2effec4c5386e97ef25f47f9d042b99bbdeba9a1e3faf87ad2a6d"
25
26 S = "${WORKDIR}/dashboard-${PV}"
27
28 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
29
30 do_install() {
31     install -d ${D}${K8S_PLUGINS}
32     install -m 644 ${WORKDIR}/kubernetes-dashboard-admin.rbac.yaml ${D}${K8S_PLUGINS}
33     install -m 644 ${S}/src/deploy/recommended/kubernetes-dashboard.yaml ${D}${K8S_PLUGINS}
34     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
35 }