meta-oran: add missing license header for recipes
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / kubernetes-dashboard_1.10.1.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "General-purpose web UI for Kubernetes clusters"
17 DESCRIPTION = "\
18   Kubernetes Dashboard is a general purpose, web-based UI \
19   for Kubernetes clusters. It allows users to manage applications \
20   running in the cluster and troubleshoot them, as well as manage \
21   the cluster itself. \
22 "
23 HOMEPAGE = "https://github.com/kubernetes/dashboard"
24
25 LICENSE = "Apache-2.0"
26 LIC_FILES_CHKSUM = "file://LICENSE;md5=b1e01b26bacfc2232046c90a330332b3"
27
28 SRC_URI = "\
29     https://github.com/kubernetes/dashboard/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
30     file://kubernetes-dashboard-admin.rbac.yaml \
31     file://kubernetes-dashboard.yaml-set-the-NodePort-type.patch \
32 "
33
34 SRC_URI[md5sum] = "52c30b2c4e9cfc31a1ea67144e81513f"
35 SRC_URI[sha256sum] = "088ba30335e2effec4c5386e97ef25f47f9d042b99bbdeba9a1e3faf87ad2a6d"
36
37 S = "${WORKDIR}/dashboard-${PV}"
38
39 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
40
41 do_install() {
42     install -d ${D}${K8S_PLUGINS}
43     install -m 644 ${WORKDIR}/kubernetes-dashboard-admin.rbac.yaml ${D}${K8S_PLUGINS}
44     install -m 644 ${S}/src/deploy/recommended/kubernetes-dashboard.yaml ${D}${K8S_PLUGINS}
45     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
46 }