meta-oran: add missing license header for recipes
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / flannel_0.12.0.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Flannel is a simple and easy way to configure a layer 3 network fabric designed for Kubernetes."
17 DESCRIPTION = "\
18   Flannel runs a small, single binary agent called flanneld on each host, \
19   and is responsible for allocating a subnet lease to each host out of a \
20   larger, preconfigured address space. Flannel uses either the Kubernetes \
21   API or etcd directly to store the network configuration, the allocated \
22   subnets, and any auxiliary data (such as the host's public IP). Packets \
23   are forwarded using one of several backend mechanisms including VXLAN and \
24   various cloud integrations. \
25 "
26 HOMEPAGE = "https://github.com/coreos/flannel"
27
28 LICENSE = "Apache-2.0"
29 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
30
31 SRC_URI = "\
32     https://github.com/coreos/flannel/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
33 "
34
35 SRC_URI[md5sum] = "1007747571bc6b8c951f72f64e567205"
36 SRC_URI[sha256sum] = "7375318b288bcff733aabfe1a1007d478cb9091cdaffe68c8253ddd93bc070ed"
37
38 S = "${WORKDIR}/${BPN}-${PV}"
39
40 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
41
42 do_install() {
43     install -d ${D}${K8S_PLUGINS}
44     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
45     install -m 644 ${S}/Documentation/kube-flannel.yml ${D}${K8S_PLUGINS}
46 }