meta-oran: add missing license header for recipes
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / cpu-manager-for-kubernetes_1.3.1.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "CPU Manager for Kubernetes"
17 uDESCRIPTION = "\
18   This project provides basic core affinity for NFV-style workloads \
19   on top of vanilla Kubernetes v1.5+. \
20   This project ships a single multi-use command-line program to perform \
21   various functions for host configuration, managing groups of CPUs, \
22   and constraining workloads to specific CPUs. \
23 "
24 HOMEPAGE = "https://github.com/intel/CPU-Manager-for-Kubernetes"
25
26 LICENSE = "Apache-2.0"
27 LIC_FILES_CHKSUM = "file://LICENSE;md5=d62f25248fea71c71fb2b520c72b5171"
28
29 SRC_URI = "\
30     https://github.com/intel/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
31     file://cmk-requirements.txt-add-urllib3-1.24.patch \
32     file://cmk-cluster-init-pod-template.yaml \
33 "
34
35 SRC_URI[md5sum] = "5ec9f665524b86654dedb2e6826851ed"
36 SRC_URI[sha256sum] = "e86feb81751c6715247577c47070beca273022b470ae09c856e6da72f185688f"
37
38 S = "${WORKDIR}/CPU-Manager-for-Kubernetes-${PV}"
39
40 K8S_PLUGINS_SRC = "/opt/kubernetes_plugins/${BPN}"
41 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
42
43 do_configure() {
44     :
45 }
46
47 do_compile() {
48     :
49 }
50
51 do_install() {
52     # Install the config files
53     install -d ${D}${K8S_PLUGINS}
54     install -m 644 ${S}/resources/authorization/cmk-serviceaccount.yaml ${D}${K8S_PLUGINS}
55     install -m 644 ${S}/resources/authorization/cmk-rbac-rules.yaml ${D}${K8S_PLUGINS}
56     install -m 644 ${WORKDIR}/cmk-cluster-init-pod-template.yaml ${D}${K8S_PLUGINS}
57
58     # Install all the src
59     install -d ${D}${K8S_PLUGINS_SRC}
60     cp -a --no-preserve=ownership ${S}/* ${D}${K8S_PLUGINS_SRC}
61 }
62
63 FILES_${PN} += "${K8S_PLUGINS_SRC}"
64
65 # provides a short alias
66 RPROVIDES_${PN} = "cmk"
67
68 INSANE_SKIP_${PN} = "file-rdeps"