meta-oran: add missing license header for recipes
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes / kubernetes_1.16.2.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 require kubernetes.inc
17
18 PV = "1.16.2+git${SRCREV_kubernetes}"
19 SRCREV_kubernetes = "c97fe5036ef3df2967d086711e6c0c405941e14b"
20 SRC_BRANCH = "release-1.16"
21
22 SRC_URI += "\
23         file://kubernetes-accounting.conf \
24         file://kubeadm.conf \
25         file://kubelet-cgroup-setup.sh \
26 "
27
28 INSANE_SKIP_${PN} += "textrel"
29 INSANE_SKIP_${PN}-misc += "textrel"
30 INSANE_SKIP_kubelet += "textrel"
31
32 SYSTEMD_AUTO_ENABLE_kubelet = "disable"
33
34 inherit go112
35
36 do_install_append() {
37     # Install the sysctl config for k8s
38     # install -d ${D}${sysconfdir}/sysctl.d/
39     # install -m 644 -D ${WORKDIR}/k8s.conf ${D}${sysconfdir}/sysctl.d/
40
41         # kubeadm:
42         install -d -m 0755 ${D}/${sysconfdir}/systemd/system/kubelete.service.d
43         install -m 0644 ${WORKDIR}/kubeadm.conf ${D}/${sysconfdir}/systemd/system/kubelete.service.d
44
45         # kubelete-cgroup-setup.sh
46         install -d -m 0755 ${D}/${bindir}
47         install -m 0644 ${WORKDIR}/kubelet-cgroup-setup.sh ${D}/${bindir}
48
49         # enable CPU and Memory accounting
50         install -d -m 0755 ${D}/${sysconfdir}/systemd/system.conf.d
51         install -m 0644 ${WORKDIR}/kubernetes-accounting.conf ${D}/${sysconfdir}//systemd/system.conf.d/
52 }
53