Add utilities
[pti/rtp.git] / meta-oran / recipes-base / packagegroups / packagegroup-oran.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Packagegroup for ORAN packages"
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
20
21 PACKAGE_ARCH = "${MACHINE_ARCH}"
22
23 inherit packagegroup
24
25 PROVIDES = "${PACKAGES}"
26 PACKAGES += " \
27     ${PN}-base \
28     ${PN}-docker \
29     ${PN}-kernel \
30     ${PN}-k8s \
31     ${PN}-vm \
32     ${PN}-trace-tools \
33     ${PN}-lttng-toolchain \
34     ${PN}-glusterfs \
35 "
36
37 RDEPENDS_${PN} = "\
38     ${PN}-base \
39     ${PN}-docker \
40     ${PN}-kernel \
41     ${PN}-k8s \
42     ${PN}-vm \
43     ${PN}-trace-tools \
44     ${PN}-lttng-toolchain \
45     ${PN}-glusterfs \
46 "
47
48 RDEPENDS_${PN}-base = "\
49     vim \
50     rt-tests \
51     tunctl \
52     udev \
53     udev-extraconf \
54     turbostat \
55     cpupower \
56     cpufrequtils \
57     msr-tools \
58     htop \
59 "
60
61 RDEPENDS_${PN}-docker = "\
62     docker \
63     docker-registry \
64 "
65
66 RDEPENDS_${PN}-kernel = "\
67     kernel-base \
68     kernel-dev \
69     kernel-devsrc \
70     kernel-modules \
71     kernel-vmlinux \
72 "
73 RDEPENDS_${PN}-k8s = "\
74     cni \
75     flannel \
76     iproute2-tc \
77     kubernetes \
78     kubernetes-dashboard \
79     node-feature-discovery \
80     multus-cni \
81 "
82
83 RDEPENDS_${PN}-vm = "\
84     qemu \
85     libvirt \
86     libvirt-libvirtd \
87     libvirt-virsh \
88     libvmi \
89 "
90
91 RRECOMMENDS_${PN}-vm = "\
92     kernel-module-kvm \
93     kernel-module-kvm-intel \
94     kernel-module-kvm-amd \
95 "
96
97 RDEPENDS_${PN}-trace-tools = "\
98     socat \
99 "
100 # It's blacklisted becasue of build failure
101 #    diod
102
103 RDEPENDS_${PN}-lttng-toolchain = "\
104     babeltrace \
105     lttng-tools \
106     lttng-ust \
107 "
108
109 RDEPENDS_${PN}-glusterfs = "\
110     fuse \
111     fuse-utils \
112     libulockmgr \
113     glusterfs \
114     glusterfs-rdma \
115     glusterfs-geo-replication \
116     glusterfs-fuse \
117     glusterfs-server \
118     xfsdump \
119     xfsprogs \
120 "