meta-oran: fix license for images and packagegroups
[pti/rtp.git] / meta-oran / recipes-base / packagegroups / packagegroup-oran.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Packagegroup for ORAN packages"
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
20
21 PACKAGE_ARCH = "${MACHINE_ARCH}"
22
23 inherit packagegroup
24
25 PROVIDES = "${PACKAGES}"
26 PACKAGES += " \
27     ${PN}-base \
28     ${PN}-docker \
29     ${PN}-k8s \
30     ${PN}-vm \
31     ${PN}-trace-tools \
32     ${PN}-lttng-toolchain \
33     ${PN}-glusterfs \
34 "
35
36 RDEPENDS_${PN} = "\
37     ${PN}-base \
38     ${PN}-docker \
39     ${PN}-k8s \
40     ${PN}-vm \
41     ${PN}-trace-tools \
42     ${PN}-lttng-toolchain \
43     ${PN}-glusterfs \
44 "
45
46 RDEPENDS_${PN}-base = "\
47     vim \
48     rt-tests \
49     tunctl \
50     udev \
51     udev-extraconf \
52 "
53
54 RDEPENDS_${PN}-docker = "\
55     docker \
56     docker-registry \
57 "
58
59 RDEPENDS_${PN}-k8s = "\
60     cni \
61     flannel \
62     iproute2-tc \
63     kubernetes \
64     kubernetes-dashboard \
65     node-feature-discovery \
66     multus-cni \
67     cmk \
68 "
69
70 RDEPENDS_${PN}-vm = "\
71     qemu \
72     libvirt \
73     libvirt-libvirtd \
74     libvirt-virsh \
75     libvmi \
76 "
77
78 RRECOMMENDS_${PN}-vm = "\
79     kernel-module-kvm \
80     kernel-module-kvm-intel \
81     kernel-module-kvm-amd \
82 "
83
84 RDEPENDS_${PN}-trace-tools = "\
85     socat \
86 "
87 # It's blacklisted becasue of build failure
88 #    diod
89
90 RDEPENDS_${PN}-lttng-toolchain = "\
91     babeltrace \
92     lttng-tools \
93     lttng-ust \
94 "
95
96 RDEPENDS_${PN}-glusterfs = "\
97     fuse \
98     fuse-utils \
99     libulockmgr \
100     glusterfs \
101     glusterfs-rdma \
102     glusterfs-geo-replication \
103     glusterfs-fuse \
104     glusterfs-server \
105     xfsdump \
106     xfsprogs \
107 "