packagegroup-oran: fix build for ARM
[pti/rtp.git] / meta-oran / recipes-base / packagegroups / packagegroup-oran.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Packagegroup for ORAN packages"
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
20
21 PACKAGE_ARCH = "${MACHINE_ARCH}"
22
23 inherit packagegroup
24
25 PROVIDES = "${PACKAGES}"
26 PACKAGES += " \
27     ${PN}-base \
28     ${PN}-docker \
29     ${PN}-kernel \
30     ${PN}-k8s \
31     ${PN}-vm \
32     ${PN}-trace-tools \
33     ${PN}-lttng-toolchain \
34     ${PN}-glusterfs \
35 "
36
37 RDEPENDS_${PN} = "\
38     ${PN}-base \
39     ${PN}-docker \
40     ${PN}-kernel \
41     ${PN}-k8s \
42     ${PN}-vm \
43     ${PN}-trace-tools \
44     ${PN}-lttng-toolchain \
45     ${PN}-glusterfs \
46 "
47
48 RDEPENDS_${PN}-base = "\
49     vim \
50     rt-tests \
51     tunctl \
52     udev \
53     udev-extraconf \
54     cpupower \
55     cpufrequtils \
56     htop \
57 "
58
59 RDEPENDS_${PN}-base_append_x86 = "\
60     turbostat \
61     msr-tools \
62 "
63
64 RDEPENDS_${PN}-base_append_x86-64 = "\
65     turbostat \
66     msr-tools \
67 "
68
69 RDEPENDS_${PN}-docker = "\
70     docker \
71     docker-registry \
72 "
73
74 RDEPENDS_${PN}-kernel = "\
75     kernel-base \
76     kernel-dev \
77     kernel-devsrc \
78     kernel-modules \
79     kernel-vmlinux \
80 "
81 RDEPENDS_${PN}-k8s = "\
82     cni \
83     flannel \
84     iproute2-tc \
85     kubernetes \
86     kubernetes-dashboard \
87     node-feature-discovery \
88     multus-cni \
89 "
90
91 RDEPENDS_${PN}-vm = "\
92     qemu \
93     libvirt \
94     libvirt-libvirtd \
95     libvirt-virsh \
96     libvmi \
97 "
98
99 RRECOMMENDS_${PN}-vm = "\
100     kernel-module-kvm \
101     kernel-module-kvm-intel \
102     kernel-module-kvm-amd \
103 "
104
105 RDEPENDS_${PN}-trace-tools = "\
106     socat \
107 "
108 # It's blacklisted becasue of build failure
109 #    diod
110
111 RDEPENDS_${PN}-lttng-toolchain = "\
112     babeltrace \
113     lttng-tools \
114     lttng-ust \
115 "
116
117 RDEPENDS_${PN}-glusterfs = "\
118     fuse \
119     fuse-utils \
120     libulockmgr \
121     glusterfs \
122     glusterfs-rdma \
123     glusterfs-geo-replication \
124     glusterfs-fuse \
125     glusterfs-server \
126     xfsdump \
127     xfsprogs \
128 "