175dfcdb1d24a3f268b68eddacef604a6eddd2d7
[pti/rtp.git] / meta-oran / recipes-base / packagegroups / packagegroup-oran.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Packagegroup for ORAN packages"
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
20
21 PACKAGE_ARCH = "${MACHINE_ARCH}"
22
23 inherit packagegroup
24
25 PROVIDES = "${PACKAGES}"
26 PACKAGES += " \
27     ${PN}-base \
28     ${PN}-docker \
29     ${PN}-kernel \
30     ${PN}-k8s \
31     ${PN}-vm \
32     ${PN}-trace-tools \
33     ${PN}-lttng-toolchain \
34     ${PN}-glusterfs \
35 "
36
37 RDEPENDS_${PN} = "\
38     ${PN}-base \
39     ${PN}-docker \
40     ${PN}-kernel \
41     ${PN}-k8s \
42     ${PN}-vm \
43     ${PN}-trace-tools \
44     ${PN}-lttng-toolchain \
45     ${PN}-glusterfs \
46 "
47
48 RDEPENDS_${PN}-base = "\
49     vim \
50     rt-tests \
51     tunctl \
52     udev \
53     udev-extraconf \
54 "
55
56 RDEPENDS_${PN}-docker = "\
57     docker \
58     docker-registry \
59 "
60
61 RDEPENDS_${PN}-kernel = "\
62     kernel-base \
63     kernel-dev \
64     kernel-devsrc \
65     kernel-modules \
66     kernel-vmlinux \
67 "
68 RDEPENDS_${PN}-k8s = "\
69     cni \
70     flannel \
71     iproute2-tc \
72     kubernetes \
73     kubernetes-dashboard \
74     node-feature-discovery \
75     multus-cni \
76     cmk \
77 "
78
79 RDEPENDS_${PN}-vm = "\
80     qemu \
81     libvirt \
82     libvirt-libvirtd \
83     libvirt-virsh \
84     libvmi \
85 "
86
87 RRECOMMENDS_${PN}-vm = "\
88     kernel-module-kvm \
89     kernel-module-kvm-intel \
90     kernel-module-kvm-amd \
91 "
92
93 RDEPENDS_${PN}-trace-tools = "\
94     socat \
95 "
96 # It's blacklisted becasue of build failure
97 #    diod
98
99 RDEPENDS_${PN}-lttng-toolchain = "\
100     babeltrace \
101     lttng-tools \
102     lttng-ust \
103 "
104
105 RDEPENDS_${PN}-glusterfs = "\
106     fuse \
107     fuse-utils \
108     libulockmgr \
109     glusterfs \
110     glusterfs-rdma \
111     glusterfs-geo-replication \
112     glusterfs-fuse \
113     glusterfs-server \
114     xfsdump \
115     xfsprogs \
116 "