c80c9056de6a7bcc56380d5e9763ed109b69f65c
[pti/rtp.git] / meta-oran / recipes-base / images / wrlinux-image-oran-host.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 DESCRIPTION = "An image suitable for a O-RAN host."
5
6 LICENSE = "MIT"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
8                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10
11 require recipes-base/images/wrlinux-image-oran-minimal.bb
12
13 IMAGE_INSTALL += " \
14     kernel-modules \
15     packagegroup-base-extended \
16     packagegroup-wr-base \
17     packagegroup-wr-base-net \
18     packagegroup-wr-boot \
19     "
20
21 IMAGE_INSTALL += " \
22    qemu \
23    tunctl \
24    udev \
25    udev-extraconf \
26    libvirt \
27    libvirt-virsh \
28    libvirt-libvirtd \
29    socat \
30    openvswitch \
31    hwloc \
32    aufs-util \
33    packagegroup-ovp-debug \
34    packagegroup-ovp-lttng-toolchain \
35    packagegroup-containers \
36    packagegroup-ovp-default-monitoring \
37    packagegroup-ovp-criu \
38    packagegroup-glusterfs \
39    packagegroup-ovp-docker \
40    spice \
41    celt051 \
42    python-pyparsing \
43    schedtool-dl \
44    dpdk \
45    system-report \
46    ceph \
47    "
48
49 IMAGE_FEATURES += " \
50     nfs-server \
51     package-management \
52     wr-core-db \
53     wr-core-interactive \
54     wr-core-net \
55     wr-core-perl \
56     wr-core-python \
57     wr-core-sys-util \
58     wr-core-util \
59     wr-core-mail \
60     "
61
62 # enable build out .ext3 image file, shall be useful for qemu
63 IMAGE_FSTYPES += "ext3"