scripts/build_oran.sh: add wrapper script
[pti/rtp.git] / meta-oran / recipes-base / images / wrlinux-image-oran-guest.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 DESCRIPTION = "An image suitable for a O-RAN guest."
5
6 LICENSE = "MIT"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
8                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10
11 require recipes-base/images/wrlinux-image-oran-minimal.bb
12
13 # OVP specific packages
14 IMAGE_INSTALL += " \
15     packagegroup-ovp-trace-tools \
16     hwloc \
17     system-report \
18     acpid-default-scripts \
19 "
20
21 IMAGE_INSTALL_append_qemux86-64 = " dpdk"
22
23 IMAGE_INSTALL += " \
24     kernel-modules \
25     packagegroup-base-extended \
26     packagegroup-wr-base \
27     packagegroup-containers \
28     packagegroup-wr-base-net \
29     packagegroup-wr-boot \
30     "
31
32 IMAGE_FEATURES += " \
33     nfs-server \
34     package-management \
35     wr-core-db \
36     wr-core-interactive \
37     wr-core-net \
38     wr-core-perl \
39     wr-core-python \
40     wr-core-sys-util \
41     wr-core-util \
42     wr-core-mail \
43     "
44
45 COMPATIBLE_MACHINE = "qemux86|qemux86-64"