Remove ovp dependency and add oran-whitelist
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-host.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 DESCRIPTION = "An image suitable for a O-RAN INF host."
5
6 LICENSE = "MIT"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
8                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10
11 require recipes-base/images/oran-image-inf-minimal.bb
12
13 IMAGE_INSTALL += " \
14     aufs-util \
15     celt051 \
16     ceph \
17     dpdk \
18     hwloc \
19     kernel-modules \
20     openvswitch \
21     packagegroup-base-extended \
22     packagegroup-oran-docker \
23     packagegroup-oran-glusterfs \
24     packagegroup-oran-lttng-toolchain \
25     packagegroup-wr-base \
26     packagegroup-wr-base-net \
27     python-pyparsing \
28     rt-tests \
29     schedtool-dl \
30     spice \
31 "
32
33 IMAGE_FEATURES += " \
34     nfs-server \
35     package-management \
36     wr-core-db \
37     wr-core-interactive \
38     wr-core-net \
39     wr-core-perl \
40     wr-core-python \
41     wr-core-sys-util \
42     wr-core-util \
43     wr-core-mail \
44 "
45
46 # enable build out .ext3 image file, shall be useful for qemu
47 IMAGE_FSTYPES += "ext3"