de8e565b3e002c8139a43a8cb89bd9eb6336dcac
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-host.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 DESCRIPTION = "An image suitable for a O-RAN INF host."
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
8
9 require recipes-base/images/oran-image-inf-minimal.bb
10
11 IMAGE_INSTALL += " \
12     aufs-util \
13     celt051 \
14     ceph \
15     dpdk \
16     hwloc \
17     kernel-modules \
18     openvswitch \
19     packagegroup-base-extended \
20     packagegroup-oran \
21     packagegroup-wr-base \
22     packagegroup-wr-base-net \
23     python-pyparsing \
24     rt-tests \
25     schedtool-dl \
26     spice \
27 "
28
29 IMAGE_FEATURES += " \
30     nfs-server \
31     package-management \
32     wr-core-db \
33     wr-core-interactive \
34     wr-core-net \
35     wr-core-perl \
36     wr-core-python \
37     wr-core-sys-util \
38     wr-core-util \
39     wr-core-mail \
40 "
41
42 # enable build out .ext3 image file, shall be useful for qemu
43 IMAGE_FSTYPES += "ext3"