meta-oran: add missing license header
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-host.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "An image suitable for a O-RAN INF host."
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
20
21 require recipes-base/images/oran-image-inf-minimal.bb
22
23 IMAGE_INSTALL += " \
24     aufs-util \
25     celt051 \
26     ceph \
27     dpdk \
28     hwloc \
29     kernel-modules \
30     openvswitch \
31     packagegroup-base-extended \
32     packagegroup-oran \
33     packagegroup-wr-base \
34     packagegroup-wr-base-net \
35     python-pyparsing \
36     rt-tests \
37     schedtool-dl \
38     spice \
39 "
40
41 IMAGE_FEATURES += " \
42     nfs-server \
43     package-management \
44     wr-core-db \
45     wr-core-interactive \
46     wr-core-net \
47     wr-core-perl \
48     wr-core-python \
49     wr-core-sys-util \
50     wr-core-util \
51     wr-core-mail \
52 "
53
54 # enable build out .ext3 image file, shall be useful for qemu
55 IMAGE_FSTYPES += "ext3"