688ffa3ca1c29eaec49a86ffbea2a798dd27504c
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-host.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 DESCRIPTION = "An image suitable for a O-RAN INF host."
5
6 LICENSE = "MIT"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
8                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10
11 require recipes-base/images/oran-image-inf-minimal.bb
12
13 IMAGE_INSTALL += " \
14     aufs-util \
15     celt051 \
16     ceph \
17     dpdk \
18     hwloc \
19     kernel-modules \
20     openvswitch \
21     packagegroup-base-extended \
22     packagegroup-oran \
23     packagegroup-wr-base \
24     packagegroup-wr-base-net \
25     python-pyparsing \
26     rt-tests \
27     schedtool-dl \
28     spice \
29 "
30
31 IMAGE_FEATURES += " \
32     nfs-server \
33     package-management \
34     wr-core-db \
35     wr-core-interactive \
36     wr-core-net \
37     wr-core-perl \
38     wr-core-python \
39     wr-core-sys-util \
40     wr-core-util \
41     wr-core-mail \
42 "
43
44 # enable build out .ext3 image file, shall be useful for qemu
45 IMAGE_FSTYPES += "ext3"