build_oran.sh: add support for nxp-lx2xxx
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-host.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "An image suitable for a O-RAN INF host."
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
20
21 require recipes-base/images/oran-image-inf-minimal.bb
22
23 IMAGE_INSTALL += " \
24     aufs-util \
25     celt051 \
26     dpdk \
27     hwloc \
28     kernel-modules \
29     openvswitch \
30     packagegroup-base-extended \
31     packagegroup-oran \
32     packagegroup-wr-base \
33     packagegroup-wr-base-net \
34     python-pyparsing \
35     rt-tests \
36     schedtool-dl \
37 "
38
39 IMAGE_INSTALL_append_x86-64 = " \
40     ceph \
41     spice \
42 "
43
44 IMAGE_FEATURES += " \
45     nfs-server \
46     package-management \
47     wr-core-db \
48     wr-core-interactive \
49     wr-core-net \
50     wr-core-perl \
51     wr-core-python \
52     wr-core-sys-util \
53     wr-core-util \
54     wr-core-mail \
55 "
56
57 # enable build out .ext3 image file, shall be useful for qemu
58 IMAGE_FSTYPES += "ext3"