51608826dfa40d988669dc4eaf9c1c263bb7b361
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-host.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 DESCRIPTION = "An image suitable for a O-RAN INF host."
5
6 LICENSE = "MIT"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
8                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10
11 require recipes-base/images/oran-image-inf-minimal.bb
12
13 IMAGE_INSTALL += " \
14     kernel-modules \
15     packagegroup-base-extended \
16     packagegroup-wr-base \
17     packagegroup-wr-base-net \
18     packagegroup-wr-boot \
19 "
20
21 IMAGE_INSTALL += " \
22     aufs-util \
23     celt051 \
24     ceph \
25     dpdk \
26     hwloc \
27     openvswitch \
28     packagegroup-containers \
29     packagegroup-glusterfs \
30     packagegroup-oran-criu \
31     packagegroup-oran-debug \
32     packagegroup-oran-default-monitoring \
33     packagegroup-oran-docker \
34     packagegroup-oran-lttng-toolchain \
35     python-pyparsing \
36     rt-tests \
37     schedtool-dl \
38     spice \
39     system-report \
40 "
41
42 IMAGE_FEATURES += " \
43     nfs-server \
44     package-management \
45     wr-core-db \
46     wr-core-interactive \
47     wr-core-net \
48     wr-core-perl \
49     wr-core-python \
50     wr-core-sys-util \
51     wr-core-util \
52     wr-core-mail \
53 "
54
55 # enable build out .ext3 image file, shall be useful for qemu
56 IMAGE_FSTYPES += "ext3"