f0f54beb68d87c9753a75ebe15c2d33081319cb8
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-guest.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 DESCRIPTION = "An image suitable for a O-RAN INF guest."
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
8
9 require recipes-base/images/oran-image-inf-minimal.bb
10
11 IMAGE_INSTALL += " \
12     acpid-default-scripts \
13     hwloc \
14     kernel-modules \
15     packagegroup-base-extended \
16     packagegroup-oran-trace-tools \
17     packagegroup-wr-base \
18     packagegroup-wr-base-net \
19 "
20 IMAGE_INSTALL_append_qemux86-64 = " dpdk"
21
22 IMAGE_FEATURES += " \
23     nfs-server \
24     package-management \
25     wr-core-db \
26     wr-core-interactive \
27     wr-core-net \
28     wr-core-perl \
29     wr-core-python \
30     wr-core-sys-util \
31     wr-core-util \
32     wr-core-mail \
33 "
34
35 COMPATIBLE_MACHINE = "qemux86|qemux86-64"