9551e064e4e2a00d94ffa5b6c7139df8a4d15b9f
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-guest.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "An image suitable for a O-RAN INF guest."
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
20
21 require recipes-base/images/oran-image-inf-minimal.bb
22
23 IMAGE_INSTALL += " \
24     acpid-default-scripts \
25     hwloc \
26     kernel-modules \
27     packagegroup-base-extended \
28     packagegroup-oran-trace-tools \
29     packagegroup-wr-base \
30     packagegroup-wr-base-net \
31 "
32 IMAGE_INSTALL_append_qemux86-64 = " dpdk"
33
34 IMAGE_FEATURES += " \
35     nfs-server \
36     package-management \
37     wr-core-db \
38     wr-core-interactive \
39     wr-core-net \
40     wr-core-perl \
41     wr-core-python \
42     wr-core-sys-util \
43     wr-core-util \
44     wr-core-mail \
45 "
46
47 COMPATIBLE_MACHINE = "qemux86|qemux86-64"