247e2e3e81c5b62b63c2aa2b6276930143782ed5
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-guest.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 DESCRIPTION = "An image suitable for a O-RAN INF guest."
5
6 LICENSE = "MIT"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
8                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10
11 require recipes-base/images/oran-image-inf-minimal.bb
12
13 IMAGE_INSTALL += " \
14     acpid-default-scripts \
15     hwloc \
16     kernel-modules \
17     packagegroup-base-extended \
18     packagegroup-containers \
19     packagegroup-oran-trace-tools \
20     packagegroup-wr-base \
21     packagegroup-wr-base-net \
22     packagegroup-wr-boot \
23     system-report \
24 "
25 IMAGE_INSTALL_append_qemux86-64 = " dpdk"
26
27 IMAGE_FEATURES += " \
28     nfs-server \
29     package-management \
30     wr-core-db \
31     wr-core-interactive \
32     wr-core-net \
33     wr-core-perl \
34     wr-core-python \
35     wr-core-sys-util \
36     wr-core-util \
37     wr-core-mail \
38 "
39
40 COMPATIBLE_MACHINE = "qemux86|qemux86-64"